cuttlefish-lon - PREMIUM - High Server load
Resolved·Degraded performance

After monitoring, we're happy this has been resolved for now. If you encounter any issues though, please contact support.

Thu, Oct 16, 2025, 09:22 AM
(1 week ago)
·
Affected components
Updates

Resolved

After monitoring, we're happy this has been resolved for now. If you encounter any issues though, please contact support.

Thu, Oct 16, 2025, 09:22 AM

Monitoring

The server appears to have stabilized, but we'll continue to monitor for changes.

Thu, Oct 16, 2025, 08:40 AM(42 minutes earlier)

Investigating

We're currently investigating an issue with sporadic spikes in load on the Premium server cuttlefish-lon.krystal.uk / 77.72.2.98

This is causing slow sites and some timeouts during the spikes. We're currently investigating this issue.

Thu, Oct 16, 2025, 08:03 AM(36 minutes earlier)