Resolved
We're happy this has been stable long enough to consider this resolved.
Monitoring
The Server is now stable. We're currently monitoring this and reviewing sources of abuse.
Investigating
We're currently seeing issues heavy load issues which are affecting the Premium server russet-lon.krystal.uk [77.72.2.79]. Updates to follow as the issue is progressed.