Resolved
We're happy this has been stable long enough to consider resolved. If you have any further issues, please contact support.
Monitoring
The server is back up and has been stable since. We're continuing to monitor this though for any issues.
Investigating
We're currently experiencing an outage with our reseller server dragonfly-lon.cloudhosting.uk.
Updates will be posted as this issue is progressed.