Resolved
We have been monitoring the server. Load averages and resource usage is within expected limits, so we're happy this issue is now resolved.
If you have any further issues, please contact support.
Monitoring
Services are running and load averages on the server are returning to normal. We're still monitoring this for further spikes.
Investigating
The server is now back up. We're currently reviewing this.
Investigating
We're currently seeing an issue with one of our reseller servers c94.lon.cloudhosting.net / 185.199.220.94
Further updates will be posted as the issue is progressed