Resolved
All servers have been patched, with full access restored and no further impact has been observed.
Please do contact our Support team via the usual channels if you experience any issues at all.
Monitoring
The cPanel patch has been deployed across the server fleet.
cPanel, WHM and Webmail access will now be available for all patched servers.
We are monitoring for any further impact. If you have any questions or experience relevant issues, please contact our Support team.
Identified
https://support.cpanel.net/hc/en-us/articles/40073787579671-Critical-Vulnerability-with-cPanel-WHM-Login-Authentication
cPanel have released a patch, which we are in the process of deploying.
Thank you for your patience.
Identified
We're currently applying precautionary restrictions to cPanel, WHM, and Webmail access following this recently disclosed security vulnerability affecting cPanel - https://support.cpanel.net/hc/en-us/articles/40073787579671-Critical-Vulnerability-with-cPanel-WHM-Login-Authentication There is no indication of any compromise to Krystal systems or customer data. This is a proactive step to remove any exposure while we await patches from cPanel. All customer websites, email delivery, and core hosting services remain fully operational. The changes are limited to cPanel and Webmail access only. Our team is closely monitoring the situation. We will restore normal access as soon as we have received confirmation from cPanel. We appreciate your understanding. As always, if you have any questions, our team is here to help.