Resolved
We're happy the abusive processes have now been mitigated. The server is in good health and we see no further signs of CPU abuse.
Identified
The cause of this has been found. System load is returning to normal and services are running as normal. We're still monitoring this though for further abuse.
Investigating
We're currently investigating a high load issue on the reseller server c96.lon.cloudhosting.net. Updates will be posted as this is progressed.