Resolved
The root cause of the issue has been confirmed and resolved.
Monitoring
The issue has been resolved and we are actively monitoring to ensure ongoing stability
Identified
We are aware of an incident causing slower than usual loading times or connection timeouts on websites hosted on haltia-lon.cloudhosting.uk. We are currently working to resolve the incident after having identified the likely cause.