Monitoring
The DNS changes queue is gradually falling which will resolve this, however we're continuing to monitor closely
Investigating
Users may see intermittent delays with making domain or DNS changes within cPanel or WHM, for example adding a domain name or changing a DNS record