Issues with outbound mail sending to Microsoft services email addresses
Identified·Degraded performance

We are continuing to see both new, and retried mail messages rejected by Microsoft, with no sign yet of successful deliveries.

This is still limited to Microsoft email services only, and other mail services are all delivering successfully.

Wed, Feb 25, 2026, 03:02 PM
(7 hours ago)
·
Affected components
Updates

Identified

We are continuing to see both new, and retried mail messages rejected by Microsoft, with no sign yet of successful deliveries.

This is still limited to Microsoft email services only, and other mail services are all delivering successfully.

Wed, Feb 25, 2026, 03:02 PM

Identified

We're aware of an issue with a number of outbound emails sent via Sirportly, to Microsoft services email addresses, i.e. outlook.com, live.com and hotmail.com/co.uk .

The errors provided by their mail servers suggest a rate-limiting issue but as this is a false-positive due to no detected increase in mail rates, or any unexpected / unsolicited mail being sent from any customers, we've requested removal directly using their SNDS system.

We'll provide further updates as soon as we have them.

Wed, Feb 25, 2026, 10:34 AM(4 hours earlier)